再手贱就剁手

前几天看到php官方发布了一个更新,修复了最近被某位百度大牛爆出的漏洞,于是就手痒想更新一下。结果天真的我不知道php版本间区别之大,从5.3直升到5.6,blog直接崩掉打不开。作为一名只会百度谷歌的脚本小子实在懒得去折腾降级,无奈只能重装系统。这下可好,php死活编译不过去,一开始说缺freetype,手动装上freetype之后又提示缺libiconv……我记得当初也没费这么大劲啊,一定是哪里姿势不正确,然后又重装系统……折腾了整整两天,系统不知道装了多少遍,最后在某论坛里看到有人讨论说只要升级php5.4以上就行了,试了下果然编译成功,一口老血差点喷到键盘上。

绕了一大圈回到了原点,两天时间白白浪费了,心好塞,还好自己有定期做备份,数据全都回来了,不然哭都没地儿哭去。